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前  言 

 

   首先感谢您选用大恒图像产品，DH-CG410 视频采集卡是我

公司新近开发的彩色/黑白视频图像采集卡。它具有使用灵活、

集成度高、功耗低等特点。由于采用 PCI 总线，所采集的图像

数据传输基本不占用 CPU 时间，并可将图像直接传送到计算机

内存或显存，是当今市场上相当流行的一种图像采集卡。它适

用于图像处理、工业控制、多媒体监控、办公自动化等领域。 

本手册详细介绍了 DH-CG410 的工作原理，软硬件安装、

使用。 
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1 概述 

1.1 技术性能及指标 

★ 支持六路复合视频输入，二路 S-VIDEO（Y/C）输入或二路 YPbPr

分量输入，软件切换。可组成： 

6 路复合视频； 

1 路 Y/C+4 路复合输入； 

2 路 Y/C+2 路复合输入； 

1 路 YPbPr+3 路复合输入； 

1 路 YPbPr+1 路 Y/C+1 路复合输入； 

2 路 YPbPr。 

★ 支持 PAL，NTSC 彩色/黑白视频输入。 

★ 支持方像素采集， 

PAL 制：768×576×24 位； 

NTSC 制：640×480×24 位。 

★ 支持 ITU-R BT.601 采集， 

PAL 制：720×576×24 位； 

NTSC 制：720×480×24 位。 

★ 可编程亮度、对比度、色度、色饱和度。 

★ A/D 转换精度 8位。 

★ 支持 YUV422、RGB8888、RGB888、RGB565、RGB555 及 Y8 模式。 

★ 图像数据数值范围，亮度：1-254 或 16-235 可选，色度：1-254

或 16-240 可选。 

★ 支持计算机内容与图像同屏显示，图形覆盖功能。 
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★ 支持图像的裁剪和比例压缩模式。 

★ 支持单场、单帧、连续场、连续帧的采集方式，图像捕捉时间，  

单场 < 40ms，单帧 < 60ms。 

★ 硬件支持图像的水平、垂直镜像。 

★ 稳定接收录像机信号。 

★ 直流噪声 < ±2 灰级。 

★ N 路（0<N<7）视频可编程定时轮流输出。 

★ 可编程固定视频输出。 

★ 提供用户可编程单片机，实现加密字等功能。 

★ 视频输入/输出 0.5V < VP-P < 1.5V，输入/输出阻抗 75Ω。 

★ 视频输入带宽 > 4MHz。 

★ 图像清晰度 > 425 线。 

★ 电源功耗 5V < 5W，-12V < 0.5W。 

★ 适用温度范围 5 - 60℃。 

★ 支持 Win9x、WinNT、Win2000、WinXP 等操作系统，支持多种

开发环境。 
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1.2 基本结构及工作原理 

 

工作原理框图 

                            

视频图像经多路切换器、解码器、A/D 变换器，将数字化的图

像数据送到数据缓冲器。经裁剪、比例压缩及数据格式转换后，

由内部控制图形覆盖与数据传输，数据传输目标位置由软件确定，

可以是显存，也可以是计算机内存。 

使用 S-VIDEO 或 YPbPr 输入时，色度分量应提供外部箝位电

路。 

 
1.3 数据格式 

RGB32(RGB8:8:8:8) 

Pixel[31:0]  

DWORD Byte3 

[31:24] 

Byte2 

[23:16] 

Byte1 

[15:8] 

Byte0 

[7:0] 

DW0 Alpha R G B 

 

 

 

3 
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RGB24(RGB8:8:8) 

Pixel[31:0]  

DWORD Byte3 

[31:24] 

Byte2 

[23:16] 

Byte1 

[15:8] 

Byte0 

[7:0] 

DW0 B1 R0 G0 B0 

DW1 G2 B2 R1 G1 

DW2 R3 G3 B3 R2 

 

RGB15(RGB5:5:5) 

Pixel[31:0]  

 

DWORD 

Byte3 

[31:24] 

Byte2 

[23:16] 

Byte1 

[15:8] 

Byte0 

[7:0] 

DW0 {0,R1[30:26],G1[25:21], 

             B1[20:16]} 

{0,R0[14:10],G0[9:5],

             B0[4:0]}

 

RGB16(RGB5:6:5) 

Pixel[31:0]  

 

DWORD 

Byte3 

[31:24] 

Byte2 

[23:16] 

Byte1 

[15:8] 

Byte0 

[7:0] 

DW0 {R1[31:27],G1[26:21],

           B1[20:16]} 

{R0[15:11],G0[10:5], 

            B0[4:0]} 
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YUV411(YUV4:1:1) 

Pixel[31:0]  

DWORD 

 

Byte3 

[31:24] 

Byte2 

[23:16] 

Byte1 

[15:8] 

Byte0 

[7:0] 

DW0 Y1 V0 YO UO 

DW1 Y3 V4 Y2 U4 

DW2 Y7 V6 Y5 Y4 

 

YUV422(YUV4:2:2) 

Pixel[31:0]  

DWORD 

 

Byte3 

[31:24] 

Byte2 

[23:16] 

Byte1 

[15:8] 

Byte0 

[7:0] 

DW0 Y1 V0 YO UO 

DW1 Y3 V2 Y2 U2 

 

Y8 

Pixel[31:0]  

DWORD 

 

Byte3 

[31:24] 

Byte2 

[23:16] 

Byte1 

[15:8] 

Byte0 

[7:0] 

DW0 Y3 Y2 Y1 Y0 

 

说明：XX[n2:n1]表示数据 XX 存储到 n1 位到 n2 位的空间中。 

 
1.4 单片机 

CG410 为用户提供单片机的功能。通过接口，用户可以编制自
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己的程序，使用单片机进行系统加密或控制操作。 
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2 安装 

2.1 产品清单 

在完整的 DH-CG410 图像采集卡产品包装中，应包括以下物品： 

√ DH-CG410 图像采集卡一块 

√ 大恒图像卡软件光盘一张 

√ 用户手册二本 

√ 视频电缆一条 

√ D15-6 路视频输入转换插头一支 

如果您购买的产品缺少上述任何一种物品，请及时与当地的供

货商联络。 

2.2 运行环境 

 与图像卡正常运行关系密切的硬件是计算机的主板和显示卡。

由于各厂家生产的主板和显示卡不尽相同，用户在使用中有时会遇

到一些问题，我们在前一阶段的测试和用户使用的基础上，总结了

在选择计算机主板和显卡时需要注意的一些问题，请用户参考。 

2.2.1 显示卡 

对于显示卡的要求主要是 DMA 传输速率、显存的读写速率。一

般来说，显示卡设置的分辨率越高，显存的读写速率就越低。关于

DMA 传输速率可参见下一节。目前市场上主流的显示卡基本都能正

常使用,一些不能正常使用的显示卡是：Trident9750；S3 

Savage3D、Savage4。 

在安装显示卡驱动程序时，应该尽量使用显示卡制造厂商提供

的驱动程序。 
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2.2.2 主机板 

     目前对主机板的要求是：提供符合 PCI2.1 标准的扩展槽，扩

展槽同时提供 5V、-12V 电源；支持 Pentium 以上 CPU（CPU 主频可

由用户根据任务需要而定）；内存 32MB 以上或按采集图像的大小

和多少而定。 

一个关键的指标是：主机板的桥路与 DMA 通道的速度，在这方

面的表现，INTEL 芯片组一般要好于 VIA 芯片组，且与 CPU 速度无

关。在使用单卡时传输速率应至少大于以下指标： 

  8 位黑白方式：15Mbyte/s 

  16 位方式：   30Mbyte/s 

  24 位方式：   45Mbyte/s 

  32 位方式：   60Mbyte/s 

 以上指标是指图像传输所需要的最小传输带宽，实际应用时应

加上主机、操作系统及其它应用设备消耗的带宽才能满足最大分辨

率的要求。注意：这里指的带宽是平均带宽，而 PCI 标称带宽指的

是瞬间带宽 132Mbyte。它们的概念是不同的。用户在选择计算机

时应充分考虑着一点。目前有许多主机板不符合以上要求，因此才

有图像采集时拉道、大窗口时图像不能实时刷新甚至不刷新的现

象。最好在购机时委托专业人士或使用图像卡当场测试。 

在使用多卡同时工作时，以上的图像传输速率应乘以卡数。当

然在使用比例压缩方式时，图像传输速率应乘以相应的压缩比，这

样可以适当降低对图像传输速率的要求。 

主机板平均数据传输速率： 
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8 位黑白方式：15Mbyte/s=K=1 

 16 位方式：    30Mbyte/s=K=2 

 24 位方式：    45Mbyte/s=K=3 

 32 位方式：    60Mbyte/s=K=4 

在比例压缩方式下： 

每路占用数据传输带宽峰值 = K×15MHz×实际窗口/768 + 应用中

操作板卡寄存器所占带宽 ≌ K×15MHz×实际窗口/768 

在裁剪方式下： 

每路占用数据传输带宽峰值 = K×15MHz + 应用中操作板卡寄存器

所占带宽 ≌ K×15MHz 

如果有 N路信号同时采集，则应确保占用总带宽 Fn = N×每

路占用数据传输带宽峰值 < 主板实际带宽。 

主板实际带宽可采用实际测试方法估算，方法是：将屏幕分辨

率设定为 1024×768×24 或 1024×768×32，运行演示程序，使用

比例压缩方式采集图像，图像窗口定为 768×576，用鼠标在水平

方向拖动窗口，直到能够正常采集图像为止，取窗口水平宽度值，

套用上面的公式即可得出主板实际带宽。如果您使用多卡同时工

作，则测试时可同时采集两路视频信号，分别设两个 768×576 的

窗口进行测试可得出 120MHz 以内的带宽。一般，主板实际带宽在

几兆到 100 兆之间不等，依主板型号有很大差异。在选用主板时应

特别注意。 
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2.3 安装图像卡硬件 

安装图像卡之前，应仔细阅读说明书。图像卡属于高科技产品，

操作不当可能会导致不可预料的结果。 

2.3.1 注意事项 

1．在从防静电包装取出图像卡之前，请先将手触摸一下金属导电

物，确保您的身体不带静电。 

2．在拿取图像卡时，尽量拿卡的边缘，不要触摸电路部分。 

3．轻拿轻放，以免碰坏卡上的器件。 

4．插拔视频输入电缆，应在主机断电后进行。 

5．开机，图像卡工作后，不要再触摸图像卡，或插拔视频输入电

缆。 

 

2.3.2 图像卡的输入、输出端口 

 
 

 

 

 

 

 

 

J2：复合视频输入（VIDEO）1 或 C2 或 Y4 

J3：Y/C 输入 2或 S-VIDEO2，板上标示：Y/C 

P2：视频输入： 

10 
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       1 VIDEO1 或 C2 或 Y4 

       2 VIDEO2 或 C1 或 Y3 

       3 VIDEO3 或 Y1 或 Pr3 

       4 VIDEO4 或 Y2 或 Pr4 

       5 VIDEO5 或 Pb3 

6–10 地线 

11 视频输出 

12–14 地线 

15 VIDEO6 或 Pb4 

J4：视频输出 

 

六路视频输入转接插头： 

1 VIDEO1 或 C2 或 Y4 

2 VIDEO2 或 C1 或 Y3 

3 VIDEO3 或 Y1 或 Pr3 

4 VIDEO4 或 Y2 或 Pr4 

5 VIDEO5 或 Pb3 

6 VIDEO6 或 Pb4 

 

2.3.3 安装步骤 

1．检查图像卡是否有损伤，如无损伤在插入计算机前最好先用橡

皮将板卡金手指擦拭干净，确保信号连接可靠。 

2．关闭计算机和所有外设的电源，打开计算机的机箱。 
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3．将图像卡插入空闲的 PCI 总线插槽中，用螺丝将金属挡片固定

在机箱上，盖好机箱。 

4．接好视频源，确保连接无误后方可接通电源。 

至此您已经完成了图像卡的硬件安装。 

 

2.4 安装图像卡设备驱动程序 

按操作系统分别说明安装过程。在安装驱动程序的同时，分配

静态内存 1000 页，即 4000KB。 

2.4.1 文件目录 

大恒图像卡软件光盘，按图像卡的型号划分目录，在 DH-CG410

的目录中，按操作系统划分驱动程序安装目录： 

\DH-CG410\Win9x、\DH-CG410\Win2000_XP 等。 

 
2.4.2 Windows9x/2000 环境下 

在安装驱动程序之前，如果是 Win2000 系统，您必须以系统管

理员身份登录。 

1．开机，启动 Win9x/2000 后，系统会报告“找到新硬件”，并提

示要求安装设备的驱动程序，单击“下一步”。 

 

12 
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2．选择“搜索适于我的设备的驱动程序（推荐）”，然后单击“下

一步”。 

 

 

 

 

 

 

 

 

 

3．在“可选的搜索位置”，选择“指定一个位置”，然后单击“下

一步”。 

 

 

13 
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4．单击“浏览”，选择驱动程序所在的路径，然后单击“确定”。 

 

 

 

 

 

 

 

 

 

 

 

5．系统找到对应的图像卡驱动程序，单击“下一步”。如果不能

14 
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正确找到驱动程序，请检查所设定的位置是否有错。 

 

 

 

 

 

 

 

 

 

6． 如果使用非 WHQL(Windows 硬件质量实验室)版本的驱动程序，

系统会提示该程序是否有微软公司的数字签名，以及“是否继

续安装?”。单击“是（Y）”。(是否经过微软认证并无大的影

响) 

 

 

 

 

 

 

 

 

 

7．安装向导开始复制文件；驱动程序安装完成，单击“完成”，

15 
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确认。 

 

 

 

 

 

 

 

 

 

 

8．随后系统提示重新启动计算机，单击“是（Y）”，重新启动。 

 

 

 

 

 

 

 

 

 

 

 

 

9．重启计算机后，打开“系统”的“设备管理器”，找到“Daheng 

16 
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CG410 Capture(05/13/2003)”设备图标，查看图标上的日期

标识和CG410的设备状态，用来确认驱动程序的安装是否成功。 

 

 

 

 

 

 

 

 

 

 

 

至此您已经完成了图像卡设备驱动程序在Win9x/2000下安装。 

 
 
 
 
 
 
 
 
 
 
 
 
 
2.4.3 WindowsXP 环境下 

在安装驱动程序之前，您必须以系统管理员身份登录。 

17 



安装         

1．开机，启动 WinXP 后，系统会报告“找到新硬件”，并提示要

求安装设备的驱动程序，这时选择“从列表或指定位置安装（高

级）”，并单击“下一步”。 

 

 

 

 

 

 

 

 

 

2．在“在这些位置上搜索最佳驱动程序”中，指定“在搜索中包

含这个位置”，单击“浏览”，选择驱动程序所在的路径，然

后单击“下一步”。 
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3．系统找 到对应

的图像卡驱动程序后，会显示识别出的图像卡的型号。如果不
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能正确找到驱动程序，请检查所设定的位置是否有错。当使用

非 WHQL(Windows 硬件质量实验室)版本的驱动程序，系统会提

示该程序没有通过 Windows 徽标测试，并询问是 “仍然继续”，

还是“停止安装”，这时单击“仍然继续”。(是否经过通过

Windows 徽标测试并无大的影响) 

 

 

 

 

 

 

 

 

 

 

4．接下来安装向导开始复制文件；确认驱动程序安装完成；随后

系统提示重新启动计算机，单击“是（Y）”，重新启动。 

 

 

 

 

 

 

 

 

19 



安装         

5．重启计算机后，打开“系统”的“设备管理器”，找到“Daheng 

CG410 Capture(05/13/2003)”设备图标，查看图标上的日期标

识和 CG410 的设备状态，用来确认驱动程序的安装是否成功。 

 

 

至此您已经完成了图像卡的设备驱动程序在 WinXP 下的安装。 
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2.4.4 WindowsNT 环境下 

在 WinNT 下使用图像卡，操作系统必须加装 Service Pack 4 

(SP4)以上的版本，由于 NT 操作系统不支持即插即用，所以要将计

算机的 BIOS 设置中的 PNP(即插即用)功能关掉(OFF)。 

在安装驱动程序之前，您必须以系统管理员身份登录。 

1．运行\DH-CG410\WinNT 目录下的安装程序 setup.exe，接下来

安装向导开始复制文件；在确认驱动程序安装完成后；系统提

示重新启动计算机，选择“Yes,I want to restart my computer  

now”，点击“Finish”重新启动。 
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2．重启计算机后，打开“控制面板”的“添加或删除程序”，找

到“Daheng CG410 Capture(05/15/2003)”图标，查看图标上

的日期标识，用来确认驱动程序的安装是否成功。 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

至此您已经完成了图像卡的设备驱动程序在 WinNT 下的安装。 
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2.5 升级图像卡设备驱动程序 

当有新版本的图像卡驱动程序时，需要对系统中的驱动程序进

行升级。 
2.5.1 Windows9x/2000 环境下 

在升级驱动程序之前，如果是 Win2000 系统，您必须以系统管

理员身份登录。 

1．打开“系统”的“设备管理器”，找到“Daheng CG410 Capture

（05/13/2003）”设备图标，双击。在“驱动程序”标签中，

选择“更新驱动程序”。 
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2．这时系统显示升级设备驱动程序向导界面，单击“下一步”。 

 

 

 

 

 

 

 

 

 

 

 

 

3．选择“显示已知设备驱动程序的列表，从中选择特定驱动程序”

项，单击“下一步”。 
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4．指定“型号：Daheng CG410 Capture（05/13/2003）”，单击

“从磁盘安装”。 

 

 

 

 

 

 

 

 

 

 

 

5．单击“浏览”，选择驱动程序所在的路径，然后单击“确定”。 
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6．指定“型号：Daheng CG410 Capture（05/13/2003）”，单击

“下一步”。如果不能正确找到驱动程序，请检查所设定的位

置是否有错。 

 

 

 

 

 

 

 

 

 

 

 

7．系统显示开始设备驱动程序安装，单击“下一步”。 

 

 

 

 

 

 

 

 

 

 

以后的操作步骤与设备驱动程序的安装相同，参见 2.4.2。 
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2.5.2 WindowsXP 环境下 

在升级驱动程序之前，您必须以系统管理员身份登录。 

打开“系统”的“设备管理器”，找到“Daheng CG410 Capture

（05/13/2003）”设备图标，双击。在“驱动程序”标签中，选择

“升级驱动程序”，这时系统显示升级设备驱动程序向导界面，选

择“从列表或指定位置安装（高级）”，并单击“下一步”。 

 

 

 

 

 

 

 

 

 

以后的操作步骤与设备驱动程序的安装相同，参见 2.4.3。 
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2.6 安装图像卡演示程序 

1．在大恒图像卡软件光盘中，运行\DH-CGCard\Performance\Setup

目录下的安装程序 Setup.exe，出现开始安装界面，单击

“Next>”。 

 

 

 

 

 

 

 

 

 

2．选择“I accept the agreement ”接受许可协议中的条款，单

击“Next>”,进入下一步。选择“I do not accept the agreement”

不接受许可协议中条款将自动退出安装程序。 
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3．选择安装路径（推荐使用默认安装路径），点击“Next>”。 

 

 

 

 

 

 

 

 

 

 

 

4．安装向导开始复制文件，并在“开始”菜单创建程序组“Daheng 

Imavision CGCard”。安装完毕后，单击“Finish”按钮确认。 

 

 

 

 

 

 

 

 

 

 

至此您已经完成了图像卡单卡演示程序 CGPerf.exe 和多卡演

示程序 CGMPerf.exe 的安装。 
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5．如果用户操作系统为 Win2000、WinXP，建议去掉菜单显示特效

和指针阴影效果，否则抓取采集到屏幕的图像时，会导致屏幕

上有图像的残留。具体操作如下： 

（1）Windows2000 

在控制面板中打开“显示”组件，选择“效果”标签，

取消“视觉效果”中的“动画显示菜单和工具提示”的“淡

入淡出效果”。 
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在控制面板中打开“鼠标”组件，选择“指针”标签，取消“启

用指针阴影”。 
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（2）WindowsXP 

在控制面板中打开“显示”组件，选择“外观”标签，

点击“效果”。 

 

 

 

 

 

 

 

 

 

 

显示“效果”对话框，取消“为菜单和工具提示使用下列过渡

效果”中的“淡入淡出效果”。 

 

 

 

 

 

 

 

 

在控制面板中打开“鼠标”组件，选择“指针”标签，取消“启

用指针阴影”，操作类似 Win2000。 
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2.7 安装图像卡软件开发包 

1．在大恒图像卡软件光盘中，运行\DH-CGCard\SDK\Setup 目录下

的安装程序 Setup.exe，出现开始安装界面，单击“Next>”。 

 

 

 

 

 

 

 

 

 

2．选择“I accept the agreement ”接受许可协议中的条款，单

击“Next>”,进入下一步。选择“I do not accept the agreement”

不接受许可协议中条款将自动退出安装程序。 
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3．选择安装路径（推荐使用默认安装路径），点击“Next>”。 

 

 

 

 

 

 

 

 

 

 

4．显示自定义安装对话框，其中 Microsoft Visual C++ 、Microsoft 

Visual Basic、Borland Delphi、Borland C++ Builder 组件分

别包括相应的开发工具示例源程序；Programming Reference  

Manual 组件包括软件开发说明书。选择要安装的组件，点击

“Next>”。 

 

 

 

 

 

 

 

 

 

34 



安装         

5．安装向导开始复制文件。安装完毕后，单击“Finish”按钮确

认。 

 

 

 

 

 

 

 

 

 

 

至此您已经完成了图像卡软件开发包的安装。 

 

用户可在相应开发工具的IDE中打开SDK的示例源程序的工程

文件，查看源程序，也可以根据需要直接修改，重新进行编译，链

接，生成新的执行程序。 
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                                    使用单卡演示程序 

3 使用单卡演示程序 

演示程序 DH-CGCard Performance 的使用说明。 

3.1 启动 

在 Windows“开始”菜单的“Daheng Imavision CGCard”程

序组中选取“One Card Performance”图标，启动演示程序。 

 
 

 

 

 

 

 

 

 

 

 

 

3.2 菜单功能 

1．File 文件操作 

Open                       打开一个位图文件。 

Save As           将当前图像保存成位图文件。 

Print                      打印图像。 

Print Preview         打印图像预览。 

Print Setup          打印设置。 

Exit            退出演示程序。 
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2．View 图像卡控制 

Capture           采集图像到屏幕，即显存。 

CaptureShot          抓取一帧/场图像到屏幕。 

Snap          使用双缓冲区，连续采集图像

到内存并显示。 

SnapShot           抓取序列图像到内存中。 

Open Series          打开序列图像文件。 

Save Series          保存序列图像。 

Playback           序列图像回放。 

->Step                逐帧回放序列图像。 

->Circle                 循环回放序列图像。 

->Stop                回放停止。 

Display           设置图像显示方式。 

->Clip                裁剪方式。 

->Scale                按比例压缩方式。 

Mask                       设置屏蔽功能。 

3．Parameter 参数设置 

Format 设置图像卡输出图像数据格

式。 

Video Standard           设置视频制式。 

Scan Mode                  设置视频扫描方式。 

Video Source               设置视频源路。 

Adjust                     调节图像的亮度、对比度、色
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调和色饱和度。 

Allocate Memory            分配静态内存。 

Interline                  图像数据存放方式。 

CryOSC Type          设置图像卡晶振频率。 

Mirror Direction         设置图像镜像方式。 

Chroma Trap in the Luma    设置视频亮度通道的陷波。 

4．Help 帮助 

About CGPerf               显示演示程序的版本号。 

 

3.3 图像卡运行 

3.3.1 采集图像到屏幕 

1．操作 

（1）点击 View->Capture 实时采集图像到屏幕上，可在窗口看到采

集的活动图像，再次点击菜单项 View->Capture 冻结当前的一

幅图像，停止采集图像到屏幕，可进行其它操作。快捷键

Ctrl+1。 

（2）点击 View->CaptureShot 抓取一帧/场图像到屏幕上。快捷键

Ctrl+2。 

2．常见问题 

（1）点击 View->Capture 出现对话框： 
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由于直接将图像采集到计算机屏幕上，这时图像卡的采

集、显示的数据格式应与主机显示卡的显示模式中的“颜色”

数保持一致。如显示卡的显示“颜色”数：256 色，对应图像

数据格式：Limited 8bit 或 All 8bit；32768 色(15 位)，对

应 RGB555；65536 色(16 位)，对应 RGB565；16mil 色(24 位)，

对应 RGB888；真彩色(32 位)，对应 RGB8888。当这些设置不

一致时，就会出现上述对话框。打开“Parameter ->Format”，

选择正确的图像数据格式。 

如果将图像采集到内存中，图像卡的数据格式和显示卡的

颜色数无关，可以单独设置。当遇到某些不能直接采集到屏幕

的显示卡（不兼容）时，可使用将图像先采集到内存中，再显

示在屏幕上的方法。 

（2）点击 View->Capture 无反应，点击 View->Snap 正常。 

说明图像无法直接采集到屏幕，可能是显示卡驱动程序或

DirectX 的版本问题，请对显示卡驱动程序进行必要的更新，

并将 DirectX 的版本升级到 8.0，特别当计算机中安装的是

Win98 第一版时，需要将其中的 DirectX 的版本进行升级。 

（3）图像采集小窗口正常，大窗口刷新速度慢、拉道严重、或根本

不刷新。 

主机板 DMA 通道速度慢，请更换另一型号主机板。 
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3.3.2 文件和打印操作 

1．操作 

（1）点击 File->Open 打开图像文件(*.bmp)。快捷键 Ctrl+O。 

（2）点击 File->Save As…保存当前图像到一指定文件(*.bmp)。 

保存图像的格式为 8位或 24 位的 BMP 文件，与当前图像

卡输出的图像数据格式有关。15 位、16 位和 32 位格式均保存

为 24 位。快捷键 Ctrl+S。 

（3）点击 File->Print 打印图像。快捷键 Ctrl+P。 

（4）点击 File->Print Preview 进行打印图像预览。 

（5）点击 File->Print Setup 进行打印设置。 

 

3.3.3 控制图像卡 

设置图像卡的图像数据格式、源路、亮度、对比度、色调、色

饱和度、采集方式、显示方式、制式、屏蔽等功能，控制图像卡的

运行。 

1．操作 

（1）点击 Parameter->Format 设置图像卡输出的图像数据格式。 

包括 YUV 422 / RGB 15Bit / RGB 16Bit / RGB 24 Bit / 

RGB 32Bit / All 8Bit / Limited 8Bit。在采集图像到屏幕

时必须保证屏幕位深度与 Format 设置一致。 

 

 

 

（2）点击 Parameter->Video Source，弹出设置源路对话框。 
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各种图像卡支持的视频源路不尽相同，请参考硬件说明。

其中点击“Default”按钮恢复默认设置。 

（3）点击 Parameter->Adjust ，弹出图像调节对话框。 

 

 

 

 

 

 

 

 

 

 

 

设置亮度(Brightness)、对比度(Contrast)、色调(Hue)、

色饱和度(Saturation)和图像扭曲调节 (PLL Freq)。图像扭
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曲调整是指在 NTSC 制式下，如果采集的图像扭曲，可通过改

变 PLL Freq 的值进行调整，注意图像扭曲调整只有 CG300、

QP300 支持。其中点击“Default”按钮恢复默认设置，点击

“Reset”按钮恢复初始设置。 

（4）点击 Parameter->Scan Mode 设置视频扫描方式。 

Frame 为帧方式，Field 为场方式。帧方式时，图像为偶

场、奇场数据交叉排列；场方式时，图像仅为偶场数据。 

（5）点击 View->Display 设置图像显示方式。 

Clip 为裁减方式，Scale 为按比例压缩方式。裁减方式时，

图像卡的视频输入窗口与输出窗口的大小是一样；按比例压缩

方式时，视频输入窗口的大小为：PAL 制为 768×576，NTSC

制为 640×480；输出窗口是变化的。在图像卡采集过程中用

户可以切换图像显示方式。 

（6）点击 Parameter->Video Standard 设置视频制式。 

包括 PAL 和 NTSC。其中 PAL 制式的最高图像分辨率

768×576；NTSC 制式的最高图像分辨率 640×480。 

（7）点击 View->Mask 打开屏蔽功能。 

如果允许屏蔽功能，则在进行图像采集时将看到在画面上

出现一个正方形保持不变的部分，即为已屏蔽的部分，屏蔽位

置的图像数据保持原来的状态，而不被实时采集的图像刷新。

屏蔽的位置和大小可通过编写程序来改变。 

（8）点击 Parameter->Interline 设置图像数据存放方式。 

采集到内存的图像数据的存放方式只有在扫描模式为
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FRAME 下有效。选中时两场交错存放，取消时两场分开存放。 

以上图像卡设置对所有大恒系列图像卡有效，而以下设置

与具体图像卡硬件有关。 

（9）点击 Parameter->CryOSC Type 设置图像卡的晶振频率。 

35M 或 28M，一般使用 CG300、CG320 卡时晶振为 35M，使

用 QP300 卡时晶振为 28M。仅 CG300、CG320、QP300 支持。 

（10）点击 Parameter->Mirror Direction 设置图像的水平和垂直

镜像。 

图像卡硬件支持图像的水平翻转 Horizon，垂直翻转

Vertical。仅 CG400、CG410 支持。 

（11）点击 Parameter->Chroma Trap in the Luma 设置视频亮度通

道的陷波。 

 

3.3.4 分配静态内存 

1．操作 

     点击 Parameter->Allocate memory 弹出分配静态内存的

对话框。 

    

 

 

 

 

 

设置 内存大

43 
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小后，要重新启动计算机才有效。  

2．注意事项 

当安装完设备驱动程序后，内存分配的初始页数是 1000。申

请内存的大小，取决于用户采集到内存图像的尺寸和数据格式的设

置。 

 
3.3.5 采集图像到内存中 

1．准备工作 

必须先成功地分配静态内存，查看内存分配对话框，检查内存

是否成功。参见 3.3.4 分配静态内存。 

2．操作 

（1）点击 View->Snap 使用双缓冲区，连续采集图像到内存并显示。

快捷键 Ctrl+3。 

如果分配的静态内存不足，提示如下信息： 

 

 

 

  

 

如果静态内存分配不成功，提示如下信息： 
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在连续采集过程中，用户可以改变显示窗口的大小。 

（2）点击 View->SnapShot 抓取序列图像到内存中，直到内存满。

采集结束后，弹出的对话框显示的数值为根据分配的内存采集

到的图像总数。快捷键 Ctrl+4。 

 

 

 

 

 

该操作完成后，可进行以下三项操作：回放(View->Play 

back)；保存采集的序列图像(View->Save Series)；打开保存

的序列图像(View->Open Series)。  

（3）Playback 为 Step 方式，回放刚采集到内存中的序列图像的第

一幅，点击鼠标左键，显示下一幅，直到最后一幅，然后再从

第一幅循环显示；Playback 为 Circle 方式，自动循环连续显

示该序列所有图像。点击 View->Playback->Stop 停止回放操

作。 

（4）Open Series：在文件打开对话框中点击选择要打开的序列图

像中的任一文件，再选择 Playback 方式进行回放，操作方式

参考 Playback 说明。 

（5）Save Series：将自动按照顺序，对采集到的序列图像加以命

名保存，如输入文件名为 abc，则存储的文件名为 abc0.bmp、

abc1.bmp 等等。 
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3．常见问题 

（1）图像采集小窗口正常，大窗口刷新速度慢、拉道严重、或根本

不刷新：主机板 DMA 通道速度慢，请更换另一型号主机板。 

（2）点击 View->Snap 无图像，无反应，点击 View->Capture 也无

图像：检查主机板是否符合图像采集的要求。 

 

 

 

 

 

 

 

 

 



                                

4 使用多卡演示程序 

演示程序 DH-CGCard Multi Performance 的使用说明。 

4.1 启动 

  在 Windows“开始”菜单的“Daheng Imavision CGCard”程

序组中选取“Multicard Performance”图标，启动演示程序。 

 

 

 

 

 

 

 

 

 

 

 

 

4.2 菜单功能 

1．File 文件操作 

Print                     打印图像。 

Print Preview             打印图像预览。 

Print Setup               打印设置。 

Exit                      退出演示程序。 

2．View 图像卡控制 

Capture          采集图像到屏幕，即显存。 

CaptureShot         抓取一帧/场图像到屏幕。 
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Snap 使用双缓冲区，连续采集图像到

内存并显示。 

SnapShot                  抓取序列图像到内存中。 

Save Series         保存序列图像。 

Playback          序列图像回放。 

->Step               逐帧回放序列图像。 

->Circle                循环回放序列图像。 

->Stop               回放停止。 

Display                   设置图像显示方式。 

->Clip               裁剪方式。 

->Scale               按比例压缩方式。 

Mask                      设置屏蔽功能。 

3．Parameter 参数设置 

 Select card                选择图像卡。 

Format                    设置图像卡输出图像数据格式。 

Video Standard          设置视频制式。 

Scan Mode                 设置视频扫描方式。 

Video Source              设置视频源路。 

Adjust                    调节图像的亮度、对比度、色调

和色饱和度。 

Allocate Memory           分配静态内存。 

Interline                 图像数据存放方式。 

CryOSC Type         设置图像卡晶振频率。 

Mirror Direction        设置图像镜像方式。 

Chroma Trap in the Luma   设置视频亮度通道的陷波。 
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4．Help 帮助 

About CGMPerf        显示演示程序的版本号。 

 

4.3 图像卡运行 

  多卡演示程序的操作与单卡演示程序基本相同，主要区别在于

菜单项 Parameter 中的菜单子项是针对某一图像卡设置的,在执行

Parameter菜单子项时，需要选定图像卡。点击Parameter-> Select 

card，弹出如下对话框，选择图像卡序号。 
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5.修改历史 

 

版本 修改内容 发布日期 修改人 

2008 年 7 月 修改第 2页的营销中心和

技术支持的联系方式 

2008-7-4 刘凤兰 
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